Partial Outage on Uploading PDFs

Resolved in 2 hours

Incident timeline

Partial outage
Resolved
2023-05-25 03:31:00 UTC - 7 months
Partial outage
Investigating
We're experiencing a partial outage on PDF file uploads at "The Lab". We're currently investigating the issue.
2023-05-25 02:00:00 UTC - 7 months